TELL ME MORE - Incompatible version of Internet Explorer detected during software installation - Rosetta Stone Support for Personal
English
×

Additional Help

>

TELL ME MORE - Incompatible version of Internet Explorer detected during software installation

The TELL ME MORE Version 10 DVD-ROM program works with Internet Explorer 8 or higher.

To fix this problem, update your version of Internet Explorer at: www.microsoft.com/windows/ie
 
If you need further assistance, please contact Rosetta Stone Product Support by clicking here.

Was this article helpful?