Rosetta Stone Support

  • FOR YOU
  • FOR CLASSROOMS & ENTERPRISES
  • SUPPORT
  • Search

    Looking for something? You're in the right place.

  • CHAT
  • Cart
  • Sign In
  • Try it free

Support

Rosetta Stone Legacy Products: Error Codes

Rosetta Stone Legacy Products: Error Codes


Use this article for troubleshooting information regarding error codes experienced in Customer Hosted Rosetta Stone programs. Please review our support policy notification for the Rosetta Stone Network Version 3 software located in the following link: http://support.rosettastone.com/en-US/Business/articles/Notification-Version-3-Customer-Hosted-Product-Support-Change-for-Schools-and-Organizations/1/

Troubleshooting information for:  

Error 1722


Resolving a 1722 error may require a fresh installation from scratch. If this occurred during a server version upgrade attempt, the database may not be recoverable.

Error 1722 is a Windows installer error that reports “Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did finish as expected. Contact your support personnel or package vendor.” and can occur for a variety of reasons. The text of the error message is often followed by an ‘Action’ with a specific name.

For example:

If you have already clicked "OK" and are unsure of the Action of your particular 1722 error, click the "How to Determine 1722 Action from the Windows Event Viewer" link below.

Note: If you encounter this error during the upgrade of an existing server installation, and you have not clicked anything such as OK, please read all the options first.  If this occurred during a server version upgrade attempt, the original database may not be recoverable.  You may need to consider a fresh installation.
 
Here is how to fix known issues: Please click the link pertaining to your Action below.
 

 
Action: ExtractNewApp

This is caused while installing the Application to a different hard drive than your operating system. If you receive this error, you should install the program to the operating system drive (usually the C: drive). If you need to save disk space you can still install the Language Levels onto a different hard drive, but we recommend using the defaults.

Return to top


Action: CreateFirewallExceptions

This error can be caused when:
  • Installing Rosetta Stone Manager Version 3 Server on an unsupported operating system. For more information, see our System Requirements
  • The Windows Firewall service is disabled.
  • You are installing a version of the Server prior to Version 3.6 Manager or Manager Server, or Network client version 3.4.3, on a 64-bit operating system.

Enabling the Windows Firewall Service 
 
Windows XP or Windows Server 2003:
 
1. Go to: Control Panel > Administrative Tools > Services.

2. If the Windows Firewall/Internet Connection Sharing (ICS) service’s Startup Type is not set to Automatic, set the Startup Type to Automatic. This service can be returned to its previous state after the installation has completed.

Windows Vista, Windows 7, or Windows Server 2008:

1. Go to: Control Panel > System Maintenance > Administrative Tools > Services.

2. If the Windows Firewall service’s Startup Type is not set to Automatic, set the Startup Type to Automatic. This service can be returned to its previous state after the installation has completed.

Return to top

 
Action: ChangeMySQLPassword

This error can be caused by:
  • Installing Rosetta Stone to a hard disk that's not home to your operating system, usually the C: drive. If you need more disk space for Rosetta Stone Language Levels, you may be able to install Language Levels to a different drive, but we recommend using the defaults instead when possible.
  • Installing under a non-administrator or otherwise restricted user account. Log-in as a local administrator if possible and restart the installation.
  • The computer in which you are installing on already has an existing general MySQL path statement. If so, you may be able to remove temporarily the path statement for the installation. 
Return to top


Action: RestoreMySQLDB
 
This error can occur during while updating Rosetta Stone Manager because Rosetta Stone's Language Data was stored somewhere other than the default location (such as a secondary hard disk drive).
 
When RestoreMySQLDB.bat file executes, it looks for a backup of your MySQL data. The backup data is usually located in:
  • C:\Documents and Settings\All Users\Application Data\Rosetta Stone Manager V3 Server Backup\rsmv3_backup.sql 
                                      Or, on Windows Vista/7/Server 2008:
  • C:\ProgramData\Rosetta Stone Manager V3 Server Backup\rsmv3_backup.sql 

If the Language Data is on a secondary drive, the backup also creates the MySQL dump on the secondary drive. When the restoration occurs, the installer looks in the wrong location for the MySQL backup data.

Note: If you cannot find your language data, you may be able to find its location by checking the InstallerDefaults.xml file: C:\Program Files\Rosetta Stone\Rosetta Stone Manager V3 Server\utility\support\config\InstallerDefaults.xml 

You may be able to Resolve this Error if you did not click anything such as OK after seeing the error:

1. Create the missing Rosetta Stone Manager V3 Server Backup folder in the following directory: 
  • C:\Documents and Settings\All Users\Application Data 
                                  Or, on Windows Vista/7/Server 2008
  • C:\ProgramData 

2. Find the rsmv3_backup.sql file.

3. Copy rsmv3_backup.sql and paste it into the new Rosetta Stone Manager V3 Server Backup folder.

You should now be able to update Rosetta Stone Manager V3 Server.

If you are still encountering Error 1722 after attempting these solutions, or have received a 1722 Error other than those mentioned in this article, please consider a fresh installation if this occurred during an upgrade attempt.

Return to top

 
How to Determine Error 1722 Action from the Windows Event Viewer
 
Windows XP/Server 2003 
  1. Open the Start Menu
  2. Right-click on "My Computer"
  3. Select "Manage"
  4. Expand Computer Management (Local) -> System Tools -> Event Viewer and select the ‘Application’ Event Log
Windows XP/Server 2003 
  1. Open the Start Menu
  2. Right-click on "Computer"
  3. Select "Manage"
  4. Expand Computer Management (Local) -> System Tools -> Event Viewer -> Windows Logs and select the ‘Application’ Event Log

Look for an entry near the time of your server installation attempt, with a Source of MsiInstaller, and an event ID of 11722.


Return to top


Return to error codes

Errors 2120, 2111, 2119
 

This error message is caused by having Trend Micro Anti-Virus installed on the local workstation where you are trying to run Rosetta Stone. To run Rosetta Stone you must disable Trend Micro Anti-virus.

Disabling Trend Micro Antivirus

1. Right-click on the "Trend Micro Anti-Virus"  icon on your taskbar

trendmicro.png

2. Select "Protection Against Spyware & Viruses"

rightclick.png

3. A pop-up window will appear asking you: "How soon do you want to automatically reactivate your protection?"

4. Select "Reactivate Manually"  from the drop-down menu

disable2.png

5. Click the "Set" button

click-set.png

6. With Trend Micro disabled you should be able to use Rosetta Stone without further difficulties

When you are done using Rosetta Stone you should reactivate your anti-virus software.
 

Reactivating Trend Micro Anti-virus

1. Right-click on the Trend Micro Anti-Virus icon in your taskbar

trendmicro.png

2. Select "Protection Against Spyware & Viruses"

reactivate.png

If you would like to be able to run Rosetta Stone without disabling your internet security software, please contact Trend Micro about setting up the applicable filters in their software.


Return to error codes

Error 2122


This issue may occur if there was a problem during an update to your Rosetta Stone Network Client application.

Correcting 2122 Database out of Date

1. Open Rosetta Stone

2. On the login page, write down the hostname or IP address that your client uses to connect to the Rosetta Stone Manager Server.

2122 Database out of Date 1

3. Close Rosetta Stone

4. Click "Start"

5. Click "My Computer"

2122 Database out of Date 2

6. Double-click "Local Disk C:"

7. Double-click "Documents and Settings"

8. Double-click "All Users"

9. Double-click "Application Data"

10. Double-click "Rosetta Stone"

11. Double-click "Network"

12. Right-click on the "tracking.db3"  file

13. Select "Delete"

2122 Database out of Date 3

14. Click "Yes"

2122 Database out of Date 4

15. Open Rosetta Stone

16. Enter the IP address or Hostname of your server

17. Click "Save Changes"

2122 Database out of Date 5

18. Sign in to Rosetta Stone


Return to error codes

Errors 2123 or 2125

 
User-added image
 
Error 2123 primarily occurs on 32- and 64-bit Windows Vista and Windows 7 workstations. This error is attributed to the application wrapper for the Rosetta Stone Network client v3.4.3. The application wrapper occasionally encounters permissions conflicts with newer Windows operating systems.  (Note: Error 2125 can be resolved using the same steps)
 
To prevent this error, always install the Rosetta Stone Network v3 Application as a local administrator when possible, and follow the steps below:

1. Close the application and restart the affected system.

2. Reopen the application and determine if the error is still occurring.

3. If the error persists, close the application, navigate to the following location on Windows Vista or 7 computers: C:\ProgramData\Rosetta Stone\Network.  Open the file dynamicStoredPaths.xml with a program suitable for editing text (such as Microsoft Notepad).  The data should look like this:
 
<installerDefaults pathToAllUsers="C:\ProgramData\Rosetta Stone\Network">
<databaseConnector>
<localDatabasePath>C:\ProgramData\Rosetta Stone\Network\tracking.db3</localDatabasePath>
</databaseConnector>
<defaultLocales>
<installerDefaultLocale>en-US</installerDefaultLocale>
</defaultLocales>
<directories>
<languageDataBasePath>C:\ProgramData\Rosetta Stone\Network\Content</languageDataBasePath>
</directories>
<trackingServiceIPAddress></trackingServiceIPAddress>
</installerDefaults>
 
Edit the data to include the IP address or host name of your server (or use 127.0.0.1 if this is a stand-alone installation) like this:
 
<installerDefaults pathToAllUsers="C:\ProgramData\Rosetta Stone\Network">
<databaseConnector>
<localDatabasePath>C:\ProgramData\Rosetta Stone\Network\tracking.db3</localDatabasePath>
</databaseConnector>
<defaultLocales>
<installerDefaultLocale>en-US</installerDefaultLocale>
</defaultLocales>
<directories>
<languageDataBasePath>C:\ProgramData\Rosetta Stone\Network\Content</languageDataBasePath>
</directories>
<trackingServiceIPAddress>YOUR IP ADDRESS</trackingServiceIPAddress>
</installerDefaults>
 
Save the dynamicStoredPaths.xml file
 
4. In the same folder, you will find a file called tracking.db3.  Delete this file.  (Note: The next time you launch the Rosetta Stone Network Version 3 client, it will generate a new tracking.db3 file).
 
5. Reboot the system and reopen the application to determine if the error is still occurring.

6. If the error still occurs, uninstall the application via the Control Panel. Delete the following folders:
  • C:\ProgramData\Rosetta Stone\Network
  • C:\Program Files\Rosetta Stone\Rosetta Stone Network Version 3 OR C:\Program Files (x86)\Rosetta Stone\Rosetta Stone Network Version 3
7. Reboot the system, ensure that you are logged in as a local administrator, and install the application from the .EXE found on the Network Application CD, not from the .MSI package.

8. If consistent with your organization’s policy, turn off User Account Control (UAC) through Control Panel>User Accounts>User Accounts>User Account Control.

9. Create a new shortcut for the Rosetta Stone Network v3 application onto your desktop by navigating to C:\Program Files\Rosetta Stone\Rosetta Stone Network Version 3 (for 32-bit operating systems) or C:\Program Files (x86)\Rosetta Stone\Rosetta Stone Network Version 3 (for 64-bit operating systems.  Right-click on RosettaStoneNetworkVersion3.exe and choose: Create Shortcut.  Drag or copy this shortcut onto your desktop.  Then try launching with the new shortcut.

10. If the solutions above do not resolve your issue, we can unfortunately no longer assist you with troubleshooting this issue.  For more information regarding our support policy for the Rosetta Stone Network v3 software, please review the notification located in the following link.


Return to error codes

Error 4112
 

The 4112 error signifies that the Rosetta Stone Network client cannot load the language data for the language assigned to learner.  If during the installation of the Rosetta Stone Server software you chose a non-default location for the language data, then you may need to reinstall the server software and select the default path for the language data.  Otherwise, please use the following steps:
 
1. Open up the Rosetta Stone Language Utility, and sign in using the super_admin login.
 
2. Select the option to remove a language, and check to see if the language your learner is using is listed.  

3. If the language is not listed, go back to the main screen, and select to add a language. When it prompts you to enter in your language CD, enter the language CD for the language level your learner is using and hit OK. Once the language is installed, close the Language Utility, and reopen the Rosetta Stone Network Version 3 learner application. Sign in as the learner and check to see if you continue to get the 4112 error.

4. If the language level is listed, you will need to remove it first. Select the language level, and click “remove the selected language”. Once the language level has been removed, reinstall it using step 3.

If this solution does not resolve your error, please be advised that the Rosetta Stone Network Version 3 Customer Hosted software is no longer supported. For more information, please review our support policy notification at the following link:

http://support.rosettastone.com/en-US/Business/articles/Notification-Version-3-Customer-Hosted-Product-Support-Change-for-Schools-and-Organizations/
 

Return to error codes

Error 5411

 
This error appears in the Rosetta Stone Customer-Hosted Network Version 3 software and signifies that the program has opened up into demonstration mode because there is not a license available on the server.  This can happen if there are no licenses activated on the server, if the licensing service is not running or cannot be reached, or if the license file itself has become damaged or corrupted.  In addition to, or in replacement of the error message, you may also see padlock icons on top of the units.
 
User-added image
 
In order to resolve this issue, you will need to have access to your server (the computer where the Rosetta Stone Server software is installed).  You may need to contact your internal IT for support if you do not have access to your server.  On a stand-alone installation, the Rosetta Stone Server software and Network clients are both installed on the same computer.
 
To begin troubleshooting this issue, click one of the Sections linked below:
If you know your licenses have not been activated yet or determine this from Section 1 see:
And lastly, if the hostname of your server has changed recently or none of these procedures resolve or expose this problem, you will want to ensure that your license file is set up correctly using:
 
 
Section 1: How to query the license server to determine the state of license codes.

For Windows Users:
 
1. On the machine where you have Rosetta Stone Manager V3 Server, browse to :
C:\Program Files\Rosetta Stone\Rosetta Stone Manager V3 Server\utility for a 32-bit operating system or C:\Program Files (x86)\Rosetta Stone\Rosetta Stone Manager V3 Server\utility for a 64-bit operating system.
 
2. Open lmtools.exe.
 
User-added image
 
3. Select the "Start/Stop/Reread" tab.
 
4. Check the "Force Server Shutdown" box.
 
5. Click "Stop Server".
The status text at the bottom of lmtools will display "Stopping Server" even after the service is stopped.
 
6. Click "Start Server".
The status text at the bottom of lmtools will display "Server Start Successful" when the service starts.
 
7. Click "ReRead License File".
The status text at the bottom of lmtools should display "Reread Server License File Completed" after a few seconds.
 
8. Go to the Server Status tab and click "Perform Status Enquiry".
 
9. Scroll to the bottom and confirm all licenses are listed. An example of currently available licenses is listed below:
Users of SK-ENG-L1-NA-PE-NA-NA-Y-3:  (Total of 1 license issued;  Total of 0 licenses in use)
Note: This line would indicate English US Level 1 as activated, with one license seat available
 
10. If the licenses are unavailable for your Language Levels or you see an error such as: FLEXnet Licensing error: -97, your license file may be damaged.  Open the file lmgrd.log which is located in the utility folder along with lmtools.exe.   If your licenses (listed as SK-XXX-LX-NA-PE-NA-NA-Y-3, or for example, in the case of English US Level 1, SK-ENG-L1-NA-PE-NA-NA-Y-3) have a notation saying they are untrusted or unsupported, then the license file has become corrupted.  If this is the case, then your licenses are un-recoverable, and your software will not continue to function without active licenses.
 
You can contact us here to request replacement licenses.  Please include order number information and specifics regarding the number of licenses for each Language Level.
 
Please also see our support policy update notification for Rosetta Stone Network V3 at the link below which contains contact information to review our current product offerings.  
Notification: Version 3 Customer Hosted Product Support Change for Schools and Organizations:
 
 

For Mac Users:
 
To be able to query the license server on your Macintosh installation you'll need to download a tool that we’ve put together for this purpose:
 
1. Download maclicensing(bundled)v1.0c.command.zip to a known location like your Desktop or Downloads folder.
 
2. Double-click on "maclicensing(bundled)v1.0c.command.zip" to extract a script named "maclicensing(bundled)v1.0c.command".
 
3. Open "maclicensing(bundled)v1.0c.command" to see the following Terminal window:
 
User-added image
 
4. Type ‘2’ and press "Enter" to Stop the License Server .
 
5. Wait about 10 seconds and type ‘1’ and press "Enter" to Start the License Server.
 
6. Type ‘3’ and press "Enter" to Reread the License File.
 
7. Type ‘4’ and press "Enter" to Perform Status Enquiry.
 
8. Once it returns with the status report scroll up in the window to find the following lines:
 
Performing Status Enquiry...
lmutil - Copyright (c) 1989-2009 Acresso Software Inc. All Rights Reserved.
Flexible License Manager status on Thu 8/18/2011 15:48
License server status: 27000 @127.0.0.1
License file(s) on 127.0.0.1: /usr/local/rsmv3/utility/rslmc.lic:
Note: If the port number/License server status, which is shown above, is 27001 or anything other than 27000, repeat steps 4-8 but this time wait longer at Step 5 and it should come up with 27000 if given enough time before starting the license server.
 
9. Scroll to the bottom and confirm all licenses are listed. An example of currently available licenses is listed below:
Users of SK-ENG-L1-NA-PE-NA-NA-Y-3: (Total of 1 license issued; Total of 0 licenses in use)
Note: This line would indicate English US Level 1 as activated, with one license seat available.
 
10. If the licenses are unavailable for your Language Levels or you see an error such as: FLEXnet Licensing error: -97, your license file may be damaged. Click Go at the top of the screen, and select "Go to Folder".  Navigate to the following location: /usr/local/rsmv3/utility. Open the file rslmc.log file.  If your licenses (listed as SK-XXX-LX-NA-PE-NA-NA-Y-3, or for example, in the case of English US Level 1, SK-ENG-L1-NA-PE-NA-NA-Y-3) have a notation saying they are untrusted or unsupported, then the license file has become corrupted.  If this is the case, then your licenses are un-recoverable, and your software will not continue to function without active licenses.  
 
You can contact us here to request replacement licenses.  Please include order number information and specifics regarding the number of licenses for each Language Level.
 
Please also see our support policy update notification for Rosetta Stone Network V3 at the link below which contains contact information to review our current product offerings.  
Notification: Version 3 Customer Hosted Product Support Change for Schools and Organizations:
 
Section 2: How to activate language levels if they have not been activated yet

If your license codes haven't been activated yet, follow these instructions on how to activate a Language Level via the Internet:
 
1. Launch Language Utility by following the steps below for your operating system:
  • Windows: Start > Program Files > Rosetta Stone > Rosetta Stone Manager V3 Server > Language Utility
  • Macintosh: Finder > Applications > Rosetta Stone Manager V3 Server > Language Utility > Rosetta Stone Version 3 Language Utility
2. Sign in using the super_admin username.
 
3. Select "Activate Products".
 
4. Enter your Activation ID exactly as it appears from the installation materials or other provided documentation.
  • Valid Version 3 activation codes appear in the form: XXXXXX-XXXXX-XXXXX-XXXXX-XXXXXX
  • Activation IDs are case sensitive.
  • The dashes are required.
User-added image
 
5. Click "Activate".
 
6. Click to confirm your license information.
 
7. Repeat steps 2-5 for all Activation IDs.
 
8. Click "Back" to Manage Languages Menu.
 
9. Click "Quit". Your licenses should now be active.
 
Note: If you want to double-check that your codes are active or you have any concerns about the licenses activating correctly, see Section 1 on how to query the license server to determine the state of your license codes.
 
If activating online is unavailable for your organization, please note that the activate by email feature of the software is no longer available.  For more information, please review our support policy notification for the Rosetta Stone Network Version 3 software located in the following link.
 


Return to top


Section 3: How to change the host information in your license file, if needed
 
For Windows Only:
 
If you have recently changed the hostname of the machine where the Manager Version 3 Server is installed then your license file may need to be updated. The license file is created upon installation with the hostname of the computer at that time so any changes to the hostname will make this file invalid and result in various errors.

To check that your license file is configured correctly, follow the steps below:

1. Open a command prompt window by going to the Start Menu > Run > Type cmd > Click "OK"

2. Type and enter "hostname" without the quotes.  This will return the value of the current computer name which should be updated in the license file.

3. Browse to C:\Program Files\Rosetta Stone\Rosetta Stone Manager V3 Server\Utility for 32-bit operating systems or C:\Program Files(x86)\Rosetta Stone\Rosetta Stone Manager V3 Server\Utility for 64-bit operating systems.

4. Open rslmc.lic with a text editor such as Notepad. It should look like this:

User-added image

5. Your rslmc.lic file should be identical to this except the hostname found in Step 2 should be in place of “yourcomputerhostname”

6. If you find that the contents of this file are not correct, update the hostname, save and close the license file.

Based on permissions it may not let you save to the utility folder directly. If this is the case, save to the desktop or other known location. Copy and overwrite the old rslmc.lic with the newly created one by dragging and dropping it into the utility folder.  Restart the licensing query as described in Section 1
 
Return to top

Return to error codes

Errors 8114, 7112, or 8114/7112

 
Experiencing the 8114 or 7112 errors individually or together can signify different issues, and are often resolved in different ways. 
  • To resolve the 8114 error by itself, click here
  • To resolve the 7112 error by itself, click here
  • To resolve the 8114/7112 error, click here

 
Error 8114
 
User-added image
 
This error signifies that the Rosetta Stone network client can reach the server, but it cannot see the Rosetta Stone licensing service. 

For Windows only:
  1. Run the following command on your server: services.msc.  This will bring up your services window.
  2. Scroll down to the R’s.  You should have between 7 and 8 services that start with Rosetta Stone.
  3. Check to make sure that all of the services are marked as started.  Specifically, check to make sure the RosettaStoneLTDLicensing service is started.  If it or any of these services is not started, try starting it manually.  If the licensing service does not start, or it starts, but does not stay started, you may need to edit your rslmc.lic file.  If the host name of this computer has changed since the installation of Rosetta Stone, the rslmc.lic file would not update automatically to reflect the new host name.  When the licensing service connects to the rslmc.lic file and sees the wrong host name, it causes the service to crash. 
  4.   Navigate to the following location: C:\Program Files\Rosetta Stone\Rosetta Stone Manager V3 Server\utility (for 32-bit operating systems) or C:\Program Files (x86)\Rosetta Stone\Rosetta Stone Manager V3 Server\utility (for 64-bit operating systems). Double-click the lmtools.exe program. Select the tab that reads: “System Settings” and note the hostname listed. 
  5.  In the same location, locate and open up the rslmc.lic file with a program suitable for editing text (such as Notepad).  If the hostname is different, edit it to reflect the new host name. 
  6. Try starting the licensing service again, or reboot your server if other Rosetta Stone services were not started.
  7. Launch the Rosetta Stone Network Version 3 application again to see if your issue has been resolved.
If the solution above does not resolve your issue, please be advised that the Rosetta Stone Network v3 software is no longer supported by Rosetta Stone.  For more information, please review our support policy notification at the following link: http://support.rosettastone.com/en-US/Business/articles/Notification-Version-3-Customer-Hosted-Product-Support-Change-for-Schools-and-Organizations/2/


For Macintosh only:
  1. Try rebooting the server first, then check to see if the issue is resolved.  If not, proceed to step 2
  2. Download the following terminal script: https://download.trstone.com/productsupport/V3_Enterprise_Installers/Utilities/License_review/Mac/maclicensing(bundled)v1.0c.command.zip
  3. Unzip the terminal script, and run it. 
  4. Select option 2 to stop the license server.  Wait approximately 20 seconds.
  5. Select option 1 to start the license server.  Wait approximately 20 seconds.
  6. Select option 3 to reread the license file
  7. Check to see if this has resolved your issue. 
If the solution above does not resolve your issue, please be advised that the Rosetta Stone Network version 3 software is no longer supported by Rosetta Stone.  For more information, please review our support policy notification at the following link: http://support.rosettastone.com/en-US/Business/articles/Notification-Version-3-Customer-Hosted-Product-Support-Change-for-Schools-and-Organizations/2/

 
Error 7112
 
User-added image

The 7112 Error signifies that the License Daemon (lmgrd) is connecting, but the application is not.
 
1. First make sure the version release of the Server matches the compatible version release of the Network Edition.  Use the following chart to determine if your version of the Server matches your version of the Network client.  (Compatible versions appear on the same row).
 
Manager ServerManager ClientNetwork Client
3.0.103.0.103.1.7N
3.2.103.2.103.2.38N
3.3.63.3.63.3.12N
3.4.33.4.33.4.3N
3.5.23.5.23.4.3N
3.6.63.6.63.4.3N
3.7.03.6.63.4.3N









































For Windows only:


To determine the version number of the Network Client, navigate to the following file folder: C:\Program Files\Rosetta Stone\Rosetta Stone Network Version 3\support\config (for 32-bit operating systems), or C:\Program Files (x86)\Rosetta Stone\Rosetta Stone Network Version 3\support\config (for 64-bit operating systems).  Here you will find a file called applicationInfo.xml.  Open this file.  Under <version> you’ll find a major, minor, and bugfix.  This corresponds to the release version of your software.  So in the example below we would have v3.4.3N:
 
<applicationInfo>
<version>
<major>3</major>
<minor>4</minor>
<bugfix>3</bugfix>
</version>
<svnUrl>
http://svn.lan.flt/svn/DWapp/ManagedRoot/dist/DogwalkApp/3.5.3.0/win/RosettaStoneNetwork
</svnUrl>
<revision>22417</revision>
<versionDate/>
</applicationInfo>
 
Now, to find the release version of the Rosetta Stone Server software, on the server, navigate to the following file folder: C:\Program Files\Rosetta Stone\Rosetta Stone Manager V3 Server\app (for 32-bit operating systems) or C:\Program Files (x86)\Rosetta Stone\Rosetta Stone Manager V3 Server\app (for 64-bit operating systems).  Here you will find another file called applicationInfo.xml.  Again, under <version> you will find a major, minor, and bugfix, which correspond to the release version of your server software, as per the below example:
 
<applicationInfo>
<version>
<major>3</major>
<minor>6</minor>
<bugfix>6</bugfix>
</version>
<revision>14135</revision>
<versionDate>2010-04-22</versionDate>
</applicationInfo>
 
In the above example, you would have v3.6.6 installed. 

 
For Macintosh only:

Open the Finder > Applications > hold down CTRL and select the Rosetta Stone Network V3 application. Select Get Info, General section you will see a Version line. Note that the installation of Rosetta Stone Network Version 3 using the 3.4.3 release displays version 3.5.3.  Treat 3.5.3 equivalent to 3.4.3.option. 
In order to see the version release of the server, in Finder > Applications, open the Rosetta Stone Manager V3 Server folder, then CTRL+click the item named Language Utility and select Show Original.  Review the file named "installed_version.txt"within /usr/local/rsmv3.

 
2. Next, check proxy settings.
 
For Windows only:

Open up Internet Explorer, select Tools > Internet Options > Connections tab > LAN Settings at the bottom: Document your settings before making any changes, as you may need to undo them.  Uncheck any selected boxes > press OK and close. (Also make sure Internet Explorer is not in Offline Mode: File > Work Offline).

For Macintosh only:

Select the Apple in the upper left corner.  Select System Preferences, then click on the Network icon. Select Ethernet, then click Advanced.  Document your settings before you make any changes, as you may need to undo them.  Make sure all box’s are unchecked, then press OK and close.
 
 
3. If both of those check out to be fine, you will need to return to the Server computer and check to make sure all the Rosetta Stone Services are up and running.
 
For Windows only:
  1. Run the following command on your server: services.msc.  This will bring up your services window.
  2. Scroll down to the R’s.  You should have between 7 and 8 services that start with Rosetta Stone.
  3. Check to make sure that all of the services are marked as started and set to automatic.  If any service is not started, try starting it manually, wait approximately 30 seconds, then proceed to the next step. 
  4. Launch the Rosetta Stone Network Version 3 application to see if your issue has been resolved. 
For Macintosh only:
  1. First, try rebooting your server.  If this does not resolve your issue, proceed to step 2.
  2. Start your Mac Terminal by going to the following location: MAC: Finder > Applications > Utilities > Terminal
  3. Enter the following command: sudo SystemStarter start.  It will then ask you for the password for the local admin login.  This will start all the installed services on the Mac.
  4. Launch the Rosetta Stone Network Version 3 application to see if your issue has been resolved.
If the solution above does not resolve your issue, please be advised that the Rosetta Stone Network Version 3 software is no longer supported by Rosetta Stone.  For more information, please review our support policy notification at the following link: http://support.rosettastone.com/en-US/Business/articles/Notification-Version-3-Customer-Hosted-Product-Support-Change-for-Schools-and-Organizations/2/

 
­­­­­­­­­
Error 8114/7112
 
User-added image

Experiencing the 8114/7112 error at the same time signifies a general disconnection.

1. Check that the IP address or Host Name in the service field for the Network application is correct.   If you are using a host name, try entering in the IP address of your server, and vice versa if you are using an IP address to see if you get a different result.  If this is a Single Station installation, try using the IP address: 127.0.0.1.  If this does not resolve your issue, try step 2.

2. Run the “ping” command to the server ip address to see if communication can be established.
  • Windows:  Start > Run > cmd >  Enter: ping ‘ip address of server’ EXAMPLE: ping 10.40.66.10
  • MAC: Finder > Applications > Utilities > Double Click the ‘Terminal’ > Enter: ping ‘ip address of server’.  If the ping command verifies connectivity, but the issue persists,  you will need to return to the Server computer to make sure all the Rosetta Stone Services are up and running.

For Windows Only:
  1. Run the following command on your server: services.msc.  This will bring up your services window.
  2. Scroll down to the R’s.  You should have between 7 and 8 services that start with Rosetta Stone.
  3. Check to make sure that all of the services are marked as started and set to automatic.  If any service is not started, try starting it manually, wait about 30 seconds, then proceed to the next step. 
  4. Launch the Rosetta Stone Network  Version 3 application to see if your issue has been resolved.
For Macintosh Only:
  1. First, try rebooting your server.  If this does not resolve your issue, proceed to step 2.
  2. Start your Mac Terminal by going to the following location: MAC: Finder > Applications > Utilities > Terminal
  3. Enter the following command: sudo SystemStarter start.  It will then ask you for the password for the local admin login.  This will start all the installed services on the Mac.
  4. Launch the Rosetta Stone Network Version 3 application to see if your issue has been resolved.

If the solution above does not resolve your issue, please be advised that the Rosetta Stone Network V3 software is no longer supported by Rosetta Stone.  For more information, please review our support policy notification at the following link: http://support.rosettastone.com/en-US/Business/articles/Notification-Version-3-Customer-Hosted-Product-Support-Change-for-Schools-and-Organizations/2/


Return to error codes

Was this article helpful?

POPULAR TOPICS
Previous MonthNext Month
SunMonTueWedThuFriSat